A Smooth Blog Move

Blog

I guess everyone who has his/her own website or blog knows the feeling. Starting a new website or blog costs time, the same counts when you move a blog to another place. Last week I switched from a free WordPress.com blog to my own domain with use of WordPress.org. Almost the same name, but a bit of a difference. The WordPress.org software is more extensive and can only be  used when you have your own domain. Luckily I didn’t have to search for a host anymore. Rudy of Brinkman.it, my trusted host since 2002 for my website http://www.nettyroyal.nl, took care of it all. I asked on Saturday morning, but he had an urgency, so finally late on Sunday evening I had the domain I wished for and even most of the software was already installed. A few tiny extras followed the next day. A firewall has been installed and a nice plugin that adds some extras for me as a moderator.

It wasn’t hard to figure out how to export all the text, photos, etc. from my old blog to the new one. And after two tries, I had imported everything to the new blog. Up to me to find a nice (and free) theme at WordPress that would allow me to have featured images, some colour, a sidebar for info. I think I succeeded rather well, although I am not 100 % happy yet, but there are always new themes coming, so who knows. A slide of the first articles, instead of some simply showing without moving. The connection to Facebook and Twitter was made soon too. With some help of WordPress also all statistics from the old blog and followers were moved here. I was advised:

Note that any of them who were signed up for email notification will need to do so again via their Reader settings. People who were only following your site via email will still receive email notifications.

Unfortunately it turned out that somehow most pictures were suddenly not attached to a post anymore. And all articles had ended up in an extra, totally wrong category that doesn’t feature on the blog itself, but turned out to be their main category according to the blog. I’ve fixed that by now. And pictures didn’t show up the way I wanted them to have – like on my old blog. Turned out I just had to make a few quick changes in the new plugin to make that happen. And at least one person couldn’t see the new blog. Probably due to the firewall. Some changes were made, so hopefully it shows correct now.

Still a few things that have to be done for sure. It seems it is the best to have featured pictures that show vertical, not horizontal. I still have to change links on my  website, make a redirection on my old blog. And I hope people who linked the blog will be so kind to change it.

Please, if anything still seems to look strange somewhere, let me know. I will try to check myself, but someone else might see other things than I do.

Leave a Reply